Vulnerability · Published Jun 9, 2026 · Assigned by apache
CVE-2026-25688Apache Answer: XSS in AI Answer Rendering
Medium 6.1
In plain English
A medium-severity security flaw in Apache Answer from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper Neutralization of Alternate XSS Syntax vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.0. AI-generated response content was rendered in the browser without proper sanitization, allowing malicious scripts to be executed when the content was viewed. Users are recommended to upgrade to version 2.0.1, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/apache/answer | 1.7.2-0.20260525024654-2746bf5b455f | GO-2026-6147 |
| Go | github.com/apache/incubator-answer | 1.7.2-0.20260525024654-2746bf5b455f | GHSA-hmr2-99jm-8x45 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Answer | 0 – through 2.0.0 |
Weakness: CWE-87 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N