Vulnerability · Published Feb 6, 2026 · Assigned by GitHub_M
CVE-2026-25631Domain allowlist bypass enables credential exfiltration
Medium 5.3
In plain English
A medium-severity improper input validation in n8n from n8n-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
n8n is an open source workflow automation platform. Prior to 1.121.0, there is a vulnerability in the HTTP Request node's credential domain validation allowed an authenticated attacker to send requests with credentials to unintended domains, potentially leading to credential exfiltration. This only might affect user who have credentials that use wildcard domain patterns (e.g., *.example.com) in the "Allowed domains" setting. This issue is fixed in version 1.121.0 and later.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | n8n | 1.121.0 | GHSA-2xcx-75h9-vr9h |
Affected products (as reported)
Weakness: CWE-20 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-2xcx-75h9-vr9h x_refsource_CONFIRM