Vulnerability · Published Feb 4, 2026 · Assigned by GitHub_M

CVE-2026-25514FacturaScripts has SQL Injection vulnerability in Autocomplete Actions

High 8.7

In plain English

A high-severity improper input validation in facturascripts from NeoRazorX. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.5%top 55.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

FacturaScripts is open-source enterprise resource planning and accounting software. Prior to version 2025.81, FacturaScripts contains a critical SQL injection vulnerability in the autocomplete functionality that allows authenticated attackers to extract sensitive data from the database including user credentials, configuration settings, and all stored business data. The vulnerability exists in the CodeModel::all() method where user-supplied parameters are directly concatenated into SQL queries without sanitization or parameterized binding. This issue has been patched in version 2025.81.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistfacturascripts/facturascripts2025.81GHSA-pqqg-5f4f-8952

Affected products (as reported)

VendorProductVersions
NeoRazorX facturascripts < 2025.81

Weakness: CWE-20, CWE-89, CWE-943 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References