Vulnerability · Published Feb 3, 2026 · Assigned by GitHub_M
CVE-2026-25235PEAR Has a Predictable Verification Hash in Election Account Requests
High 8.2
In plain English
A high-severity security flaw in pearweb from pear. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities).
Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.3%top 78.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
PEAR is a framework and distribution system for reusable PHP components. Prior to version 1.33.0, predictable verification hashes may allow attackers to guess verification tokens and potentially verify election account requests without authorization. This issue has been patched in version 1.33.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Ubuntu:22.04:LTS | php-pear | no fix listed | UBUNTU-CVE-2026-25235 |
| Ubuntu:24.04:LTS | php-pear | no fix listed | UBUNTU-CVE-2026-25235 |
| Ubuntu:25.10 | php-pear | no fix listed | UBUNTU-CVE-2026-25235 |
Affected products (as reported)
Weakness: CWE-337 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/pear/pearweb/security/advisories/GHSA-477r-4cmw-3cgf x_refsource_CONFIRM