Vulnerability · Published Feb 2, 2026 · Assigned by GitHub_M
CVE-2026-25060OpenList Insecure TLS Default Configuration
High 8.1
In plain English
A high-severity security flaw in OpenList from OpenListTeam. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenList Frontend is a UI component for OpenList. Prior to 4.1.10, certificate verification is disabled by default for all storage driver communications. The TlsInsecureSkipVerify setting is default to true in the DefaultConfig() function in internal/conf/config.go. This vulnerability enables Man-in-the-Middle (MitM) attacks by disabling TLS certificate verification, allowing attackers to intercept and manipulate all storage communications. Attackers can exploit this through network-level attacks like ARP spoofing, rogue Wi-Fi access points, or compromised internal network equipment to redirect traffic to malicious endpoints. Since certificate validation is skipped, the system will unknowingly establish encrypted connections with attacker-controlled servers, enabling full decryption, data theft, and manipulation of all storage operations without triggering any security warnings. This vulnerability is fixed in 4.1.10.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/OpenListTeam/OpenList | no fix listed | GO-2026-4397 |
| Go | github.com/OpenListTeam/OpenList/v3 | no fix listed | GO-2026-4397 |
| Go | github.com/OpenListTeam/OpenList/v4 | 4.1.10 | GHSA-wf93-3ghh-h389 |
| Go | github.com/OpenListTeam/OpenList/v4 | 4.1.10 | GO-2026-4397 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenListTeam | OpenList | < 4.1.10 |
Weakness: CWE-599 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H