Vulnerability · Published Feb 4, 2026 · Assigned by GitHub_M
CVE-2026-25054n8n is Vulnerable to Stored Cross-Site Scripting via Markdown Rendering in Workflow UI
High 8.5
In plain English
A high-severity cross-site scripting in n8n from n8n-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
n8n is an open source workflow automation platform. Prior to versions 1.123.9 and 2.2.1, a Cross-Site Scripting (XSS) vulnerability existed in a markdown rendering component used in n8n's interface, including workflow sticky notes and other areas that support markdown content. An authenticated user with permission to create or modify workflows could abuse this to execute scripts with same-origin privileges when other users interact with a maliciously crafted workflow. This could lead to session hijacking and account takeover. This issue has been patched in versions 1.123.9 and 2.2.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | n8n | 2.2.1 | GHSA-qpq4-pw7f-pp8w |
| npm | n8n | 1.123.9 | GHSA-qpq4-pw7f-pp8w |
Affected products (as reported)
Weakness: CWE-80, CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-qpq4-pw7f-pp8w x_refsource_CONFIRM