Vulnerability · Published Feb 4, 2026 · Assigned by GitHub_M
CVE-2026-25049n8n Has an Expression Escape Vulnerability Leading to RCE
Critical 9.4
In plain English
A critical-severity security flaw in n8n from n8n-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 75% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
n8n is an open source workflow automation platform. Prior to versions 1.123.17 and 2.5.2, an authenticated user with permission to create or modify workflows could abuse crafted expressions in workflow parameters to trigger unintended system command execution on the host running n8n. This issue has been patched in versions 1.123.17 and 2.5.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | n8n | 1.123.17 | GHSA-6cqr-8cfr-67f8 |
| npm | n8n | 2.5.2 | GHSA-6cqr-8cfr-67f8 |
Affected products (as reported)
Weakness: CWE-913 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H