Vulnerability · Published Apr 3, 2026 · Assigned by GitHub_M

CVE-2026-25044Budibase: Command Injection in Bash Automation Step

High 8.7

In plain English

A high-severity OS command injection in budibase from Budibase. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.5%top 58.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Budibase is an open-source low-code platform. Prior to version 3.33.4, the bash automation step executes user-provided commands using execSync without proper sanitization or validation. User input is processed through processStringSync which allows template interpolation, potentially allowing arbitrary command execution. This issue has been patched in version 3.33.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@budibase/server3.33.4GHSA-gjw9-34gf-rp6m

Affected products (as reported)

VendorProductVersions
Budibase budibase < 3.33.4

Weakness: CWE-78 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References