Vulnerability · Published Apr 14, 2026 · Assigned by GitHub_M
CVE-2026-24906October CMS has Stored XSS in its Backend Editor Markup Classes
Medium 5.1
In plain English
A medium-severity cross-site scripting in october from octobercms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
October is a Content Management System (CMS) and web platform. Versions prior to 3.7.14 and 4.1.10 contain a Stored Cross-Site Scripting (XSS) vulnerability in the Backend Editor Settings. The Markup Classes fields (used for paragraph styles, inline styles, table styles, etc.) did not sanitize input to valid CSS class name characters. Malicious values were rendered unsanitized in Froala editor dropdown menus, allowing JavaScript execution when any user opened a RichEditor. Exploitation could lead to privilege escalation if a superuser opens any RichEditor during routine content editing (e.g., editing a blog post), and requires authenticated backend access with editor settings permissions. This issue has been fixed in versions 3.7.14 and 4.1.10. To workaround this issue, restrict editor settings permissions to fully trusted administrators only
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | october/system | 4.1.10 | GHSA-6qmh-j78v-ffp7 |
| Packagist | october/system | 3.7.14 | GHSA-6qmh-j78v-ffp7 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| octobercms | october | < 3.7.14>= 4.0.0, < 4.1.10 |
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/octobercms/october/security/advisories/GHSA-6qmh-j78v-ffp7 x_refsource_CONFIRM