Vulnerability · Published Apr 9, 2026 · Assigned by apache

CVE-2026-24880Apache Tomcat: Request smuggling via invalid chunk extension

High 7.5

In plain English

A high-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.7%top 46.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache Tomcat via invalid chunk extension. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M1 through 10.1.52, from 9.0.0.M1 through 9.0.115, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other, unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.20, 10.1.52 or 9.0.116, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-admin-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-admin-webapps1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-docs-webapp1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-docs-webapp1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-el-3.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-el-3.0-api1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-lib1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-lib1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-webapps1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:10tomcat91:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat91:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-admin-webapps1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-admin-webapps1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-docs-webapp1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-docs-webapp1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-el-3.0-api1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-el-3.0-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-jsp-2.3-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-jsp-2.3-api1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-lib1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-lib1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-servlet-4.0-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-servlet-4.0-api1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-webapps1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-webapps1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
Debian:12tomcat1010.1.55-1~deb12u1DEBIAN-CVE-2026-24880
Debian:13tomcat1010.1.55-1~deb13u1DEBIAN-CVE-2026-24880
Debian:14tomcat1010.1.54-1DEBIAN-CVE-2026-24880
Debian:13tomcat1111.0.22-1~deb13u1DEBIAN-CVE-2026-24880
Debian:14tomcat1111.0.21-1DEBIAN-CVE-2026-24880
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-24880
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-24880
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-24880
Mavenorg.apache.tomcat.embed:tomcat-embed-core11.0.20GHSA-563x-q5rq-57qp
Mavenorg.apache.tomcat.embed:tomcat-embed-core9.0.116GHSA-563x-q5rq-57qp
Mavenorg.apache.tomcat.embed:tomcat-embed-core10.1.52GHSA-563x-q5rq-57qp
Mavenorg.apache.tomcat:tomcat-coyote11.0.20GHSA-563x-q5rq-57qp
Mavenorg.apache.tomcat:tomcat-coyote10.1.52GHSA-563x-q5rq-57qp
Mavenorg.apache.tomcat:tomcat-coyote9.0.116GHSA-563x-q5rq-57qp
Rocky Linux:10tomcat91:9.0.117-1.el10_2RLSA-2026:25341
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2026-24880
Ubuntu:25.10tomcat10no fix listedUBUNTU-CVE-2026-24880
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2026-24880
Ubuntu:25.10tomcat11no fix listedUBUNTU-CVE-2026-24880
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-24880
Ubuntu:24.04:LTStomcat9no fix listedUBUNTU-CVE-2026-24880
Ubuntu:25.10tomcat9no fix listedUBUNTU-CVE-2026-24880
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-24880

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.1810.1.0-M1 – through 10.1.529.0.0.M1 – through 9.0.1158.5.0 – through 8.5.1007.0.0 – through 7.0.109

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References