Vulnerability · Published Feb 4, 2026 · Assigned by GitHub_M
CVE-2026-24844melange pipeline working-directory could allow command injection
High 7.8
In plain English
A high-severity OS command injection in melange from chainguard-dev. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
melange allows users to build apk packages using declarative pipelines. From version 0.3.0 to before 0.40.3, an attacker who can provide build input values, but not modify pipeline definitions, could execute arbitrary shell commands if the pipeline uses ${{vars.*}} or ${{inputs.*}} substitutions in working-directory. The field is embedded into shell scripts without proper quote escaping. This issue has been patched in version 0.40.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | chainguard.dev/melange | 0.40.3 | GHSA-vqqr-rmpc-hhg2 |
| Go | chainguard.dev/melange | 0.40.3 | GO-2026-4408 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| chainguard-dev | melange | >= 0.3.0, < 0.40.3 |
Weakness: CWE-78 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N