Vulnerability · Published Feb 17, 2026 · Assigned by apache

CVE-2026-24733Apache Tomcat: Security constraint bypass with HTTP/0.9

Medium 6.5

In plain English

A medium-severity improper input validation in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 46% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.6%top 53.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-admin-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-admin-webapps1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-docs-webapp1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-docs-webapp1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-el-3.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-el-3.0-api1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-lib1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-lib1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:8tomcat-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-webapps1:9.0.117-1.el9_8ALSA-2026:26323
AlmaLinux:10tomcat91:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat91:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-admin-webapps1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-admin-webapps1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-docs-webapp1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-docs-webapp1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-el-3.0-api1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-el-3.0-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-jsp-2.3-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-jsp-2.3-api1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-lib1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-lib1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-servlet-4.0-api1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-servlet-4.0-api1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
AlmaLinux:10tomcat9-webapps1:9.0.117-2.el10_2.alma.1ALSA-2026:36790
AlmaLinux:10tomcat9-webapps1:9.0.117-1.el10_2.alma.1ALSA-2026:25341
Debian:12tomcat1010.1.52-1~deb12u1DEBIAN-CVE-2026-24733
Debian:12tomcat1010.1.52-1~deb12u1DSA-6120-1
Debian:13tomcat1010.1.52-1~deb13u1DSA-6120-1
Debian:13tomcat1010.1.52-1~deb13u1DEBIAN-CVE-2026-24733
Debian:14tomcat1010.1.52-1DEBIAN-CVE-2026-24733
Debian:13tomcat1111.0.15-1~deb13u1DEBIAN-CVE-2026-24733
Debian:13tomcat1111.0.15-1~deb13u1DSA-6121-1
Debian:14tomcat1111.0.15-1DEBIAN-CVE-2026-24733
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-24733
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-24733
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-24733
Mavenorg.apache.tomcat:tomcat-coyote10.1.50GHSA-qq5r-98hh-rxc9
Mavenorg.apache.tomcat:tomcat-coyote11.0.15GHSA-qq5r-98hh-rxc9
Mavenorg.apache.tomcat:tomcat-coyote9.0.113GHSA-qq5r-98hh-rxc9
Rocky Linux:10tomcat91:9.0.117-1.el10_2RLSA-2026:25341
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2026-24733
Ubuntu:25.10tomcat10no fix listedUBUNTU-CVE-2026-24733
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2026-24733
Ubuntu:25.10tomcat11no fix listedUBUNTU-CVE-2026-24733
Ubuntu:24.04:LTStomcat9no fix listedUBUNTU-CVE-2026-24733
Ubuntu:25.10tomcat9no fix listedUBUNTU-CVE-2026-24733

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.1410.1.0-M1 – through 10.1.499.0.0.M1 – through 9.0.1120 – through 8.5.100

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

References