Vulnerability · Published Mar 9, 2026 · Assigned by apache
CVE-2026-24713Apache IoTDB: JEXL Expression Injection Vulnerability
Critical 9.8
In plain English
A critical-severity improper input validation in Apache IoTDB from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)0.7%top 45.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Improper Input Validation vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7. Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.iotdb:iotdb-core | 1.3.7 | GHSA-6w48-2g9j-v9q5 |
| Maven | org.apache.iotdb:iotdb-core | 2.0.7 | GHSA-6w48-2g9j-v9q5 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache IoTDB | 1.0.0 – before 1.3.72.0.0 – before 2.0.7 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H