Vulnerability · Published Jan 24, 2026 · Assigned by GitHub_M
CVE-2026-24421phpMyFAQ missing authorization exposes /api/setup/backup to any authenticated user
Medium 6.5
In plain English
A medium-severity missing authorization in phpMyFAQ from thorsten. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 78% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
phpMyFAQ is an open source FAQ web application. Versions 4.0.16 and below have flawed authorization logic which exposes the /api/setup/backup endpoint to any authenticated user despite their permissions. SetupController.php uses userIsAuthenticated() but does not verify that the requester has configuration/admin permissions. Non-admin users can trigger a configuration backup and retrieve its path. The endpoint only checks authentication, not authorization, and returns a link to the generated ZIP. This issue is fixed in version 4.0.17.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | phpmyfaq/phpmyfaq | 4.0.17 | GHSA-wm8h-26fv-mg7g |
| Packagist | thorsten/phpmyfaq | 4.0.17 | GHSA-wm8h-26fv-mg7g |
Affected products (as reported)
Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-wm8h-26fv-mg7g x_refsource_CONFIRM