Vulnerability · Published Jan 24, 2026 · Assigned by GitHub_M
CVE-2026-24399ChatterMate has Stored Cross-Site Scripting (XSS) via Chatbot Input Execution
Critical 9.3
In plain English
A critical-severity cross-site scripting in chattermate.chat from chattermate. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities).
Official description
ChatterMate is a no-code AI chatbot agent framework. In versions 1.0.8 and below, the chatbot accepts and executes malicious HTML/JavaScript payloads when supplied as chat input. Specifically, an <iframe> payload containing a javascript: URI can be processed and executed in the browser context. This allows access to sensitive client-side data such as localStorage tokens and cookies, resulting in client-side injection. This issue has been fixed in version 1.0.9.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| chattermate | chattermate.chat | < 1.0.9 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
References
- https://github.com/chattermate/chattermate.chat/security/advisories/GHSA-72p3-w95w-q3j4 x_refsource_CONFIRM
- https://github.com/chattermate/chattermate.chat/commit/ff3398031abb97ae28546eaf993fed3619eaffdd x_refsource_MISC
- https://github.com/chattermate/chattermate.chat/releases/tag/v1.0.9 x_refsource_MISC