Vulnerability · Published Mar 7, 2026 · Assigned by apache

CVE-2026-24308Apache ZooKeeper: Sensitive information disclosure in client configuration handling

Medium 6.5

In plain English

A medium-severity sensitive data in logs in Apache ZooKeeper from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)1.3%top 29.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper handling of configuration values in ZKConfig in Apache ZooKeeper 3.8.5 and 3.9.4 on all platforms allows an attacker to expose sensitive information stored in client configuration in the client's logfile. Configuration values are exposed at INFO level logging rendering potential production systems affected by the issue. Users are recommended to upgrade to version 3.8.6 or 3.9.5 which fixes this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12zookeeperno fix listedDEBIAN-CVE-2026-24308
Debian:13zookeeperno fix listedDEBIAN-CVE-2026-24308
Debian:14zookeeper3.9.5-1DEBIAN-CVE-2026-24308
Mavenorg.apache.zookeeper:zookeeper3.9.5GHSA-crhr-qqj8-rpxc
Mavenorg.apache.zookeeper:zookeeper3.8.6GHSA-crhr-qqj8-rpxc
Ubuntu:22.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-24308
Ubuntu:24.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-24308
Ubuntu:25.10zookeeperno fix listedUBUNTU-CVE-2026-24308
Ubuntu:26.04:LTSzookeeperno fix listedUBUNTU-CVE-2026-24308
Ubuntu:26.10zookeeperno fix listedUBUNTU-CVE-2026-24308

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ZooKeeper 3.9.0 – through 3.9.43.8.0 – through 3.8.5

Weakness: CWE-532, CWE-117 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

References