Vulnerability · Published Jan 22, 2026 · Assigned by GitHub_M
CVE-2026-24130Moonraker with LDAP Enabled Allows Malicious Search Filter Injection
Low 2.7
In plain English
A low-severity security flaw in moonraker from Arksine. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Moonraker is a Python web server providing API access to Klipper 3D printing firmware. In versions 0.9.3 and below, instances configured with the "ldap" component enabled are vulnerable to LDAP search filter injection techniques via the login endpoint. The 401 error response message can be used to determine whether or not a search was successful, allowing for brute force methods to discover LDAP entries on the server such as user IDs and user attributes. This issue has been fixed in version 0.10.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | moonraker | 0.10.0 | GHSA-3jqf-v4mv-747g |
| PyPI | moonraker | 0.10.0 | PYSEC-2026-1679 |
Affected products (as reported)
Weakness: CWE-90, CWE-209 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U