Vulnerability · Published May 4, 2026 · Assigned by apache

CVE-2026-24072Apache HTTP Server: mod_rewrite elevation of privileges via ap_expr

High 8.8

In plain English

A high-severity privilege mismanagement in Apache HTTP Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.7%top 48.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

An escalation of privilege bug in various modules in Apache HTTP 2.4.66 and earlier allows local .htaccess authors to read files with the privileges of the httpd user. Users are recommended to upgrade to version 2.4.67, which fixes this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10httpd2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9httpd2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10httpd-core2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9httpd-core2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10httpd-devel2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9httpd-devel2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10httpd-filesystem2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9httpd-filesystem2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10httpd-manual2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9httpd-manual2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10httpd-tools2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9httpd-tools2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10mod_ldap2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9mod_ldap2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10mod_lua2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9mod_lua2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10mod_proxy_html1:2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9mod_proxy_html1:2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10mod_session2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9mod_session2.4.62-13.el9_8.5ALSA-2026:41906
AlmaLinux:10mod_ssl1:2.4.63-13.el10_2.4ALSA-2026:34109
AlmaLinux:9mod_ssl1:2.4.62-13.el9_8.5ALSA-2026:41906
Alpine:v3.20apache22.4.67-r0ALPINE-CVE-2026-24072
Alpine:v3.21apache22.4.67-r0ALPINE-CVE-2026-24072
Alpine:v3.22apache22.4.67-r0ALPINE-CVE-2026-24072
Alpine:v3.23apache22.4.67-r0ALPINE-CVE-2026-24072
Alpine:v3.24apache22.4.67-r0ALPINE-CVE-2026-24072
Debian:12apache22.4.67-1~deb12u2DEBIAN-CVE-2026-24072
Debian:13apache22.4.67-1~deb13u2DEBIAN-CVE-2026-24072
Debian:14apache22.4.67-1DEBIAN-CVE-2026-24072
Rocky Linux:9httpd0:2.4.62-13.el9_8.5RLSA-2026:41906
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.20UBUNTU-CVE-2026-24072
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.12UBUNTU-CVE-2026-24072
Ubuntu:25.10apache22.4.64-1ubuntu3.4UBUNTU-CVE-2026-24072
Ubuntu:26.04:LTSapache22.4.66-2ubuntu2.1UBUNTU-CVE-2026-24072

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache HTTP Server 0 – through 2.4.66

Weakness: CWE-269 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References