Vulnerability · Published Jan 22, 2026 · Assigned by GitHub_M

CVE-2026-24058Soft Serve has Critical Authentication Bypass

High 8.1

In plain English

A high-severity security flaw in soft-serve from charmbracelet. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.1High
Exploit odds (30 days)0.6%top 52.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Soft Serve is a self-hostable Git server for the command line. Versions 0.11.2 and below have a critical authentication bypass vulnerability that allows an attacker to impersonate any user (including admin) by "offering" the victim's public key during the SSH handshake before authenticating with their own valid key. This occurs because the user identity is stored in the session context during the "offer" phase and is not cleared if that specific authentication attempt fails. This issue has been fixed in version 0.11.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/charmbracelet/soft-serve0.11.3GHSA-pchf-49fh-w34r
Gogithub.com/charmbracelet/soft-serve0.11.3GO-2026-4353

Affected products (as reported)

VendorProductVersions
charmbracelet soft-serve < 0.11.3

Weakness: CWE-289 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

References