Vulnerability · Published Feb 24, 2026 · Assigned by apache

CVE-2026-23983Apache Superset: Sensitive Data Exposure via REST API (disabled by default)

Low 2.3

In plain English

A low-severity information exposure in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.3Low
Exploit odds (30 days)0.5%top 59.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A Sensitive Data Exposure vulnerability exists in Apache Superset allowing authenticated users to retrieve sensitive user information. The Tag endpoint (disabled by default) allows users to retrieve a list of objects associated with a specific tag. When these associated objects include Users, the API response improperly serializes and returns sensitive fields, including password hashes (pbkdf2), email addresses, and login statistics. This vulnerability allows authenticated users with low privileges (e.g., Gamma role) to view sensitive authentication data This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue or make sure TAGGING_SYSTEM is False (Apache Superset current default)

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-superset6.0.0GHSA-h294-8fxm-m2pj
PyPIapache-superset6.0.0PYSEC-2026-2375

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Superset 0.0.0 – before 6.0.0

Weakness: CWE-200 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

References