Vulnerability · Published Feb 24, 2026 · Assigned by apache

CVE-2026-23982Apache Superset: Improper Authorization in Dataset Creation Allows Access Control Bypass

High 7.1

In plain English

A high-severity incorrect authorization in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.1High
Exploit odds (30 days)0.5%top 56.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

An Improper Authorization vulnerability exists in Apache Superset that allows a low-privileged user to bypass data access controls. When creating a dataset, Superset enforces permission checks to prevent users from querying unauthorized data. However, an authenticated attacker with permissions to write datasets and read charts can bypass these checks by overwriting the SQL query of an existing dataset. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-superset6.0.0GHSA-3m2g-v7jf-7fxc
PyPIapache-superset6.0.0PYSEC-2026-2372

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Superset 0.0.0 – before 6.0.0

Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References