Vulnerability · Published Apr 13, 2026 · Assigned by GitHub_M

CVE-2026-23891Decidim has a Cross-site scripting (XSS) vulnerability via user name field

Critical 9.3

In plain English

A critical-severity cross-site scripting in decidim from decidim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.3Critical
Exploit odds (30 days)0.4%top 70.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Decidim is a participatory democracy framework. In versions below 0.30.5 and 0.31.0.rc1 through 0.31.0, a stored code execution vulnerability in the user name field allows a low-privileged attacker to execute arbitrary code in the context of any user who passively visits a comment page, resulting in high confidentiality and integrity impact across security boundaries. This issue has been fixed in versions 0.30.5 and 0.31.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsdecidim-core0.31.1GHSA-fc46-r95f-hq7g
RubyGemsdecidim-core0.30.5GHSA-fc46-r95f-hq7g

Affected products (as reported)

VendorProductVersions
decidim decidim >= 0.31.0.rc1, < 0.31.1< 0.30.5

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L

References