Vulnerability · Published Feb 3, 2026 · Assigned by apache
CVE-2026-23794Apache Syncope: Reflected XSS on Enduser Login
Medium 6.8
In plain English
A medium-severity cross-site scripting in Apache Syncope from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Reflected XSS in Apache Syncope's Enduser Login page. An attacker that tricks a legitimate user into clicking a malicious link and logging in to Syncope Enduser could steal that user's credentials. This issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3. Users are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui | 3.0.16 | GHSA-v84m-gfw5-hm2w |
| Maven | org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui | 4.0.4 | GHSA-v84m-gfw5-hm2w |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Syncope | 3.0 – through 3.0.154.0 – through 4.0.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N