Vulnerability · Published Feb 27, 2026 · Assigned by openjs
CVE-2026-2359Multer vulnerable to Denial of Service via resource exhaustion
High 7.5
In plain English
A high-severity security flaw in multer from expressjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by dropping connection during file upload, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | multer | 2.1.0 | GHSA-v52c-386h-88mc |
Affected products (as reported)
Weakness: CWE-772 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/expressjs/multer/security/advisories/GHSA-v52c-386h-88mc
- https://www.cve.org/CVERecord?id=CVE-2026-2359
- https://github.com/expressjs/multer/commit/cccf0fe0e64150c4f42ccf6654165c0d66b9adab
- https://cna.openjsf.org/security-advisories.html
- https://access.redhat.com/security/cve/CVE-2026-2359 vdb-entry, x_refsource_REDHAT
- RHBZ#2443350 issue-tracking, x_refsource_REDHAT
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-2359.json x_sadp-csaf-vex
- https://access.redhat.com/errata/RHSA-2026:6174 vendor-advisory, x_refsource_REDHAT
- https://access.redhat.com/errata/RHSA-2026:6802 vendor-advisory, x_refsource_REDHAT