Vulnerability · Published Jan 14, 2026 · Assigned by GitHub_M
CVE-2026-23498Shopware Improper Control of Generation of Code in Twig rendered views
High 7.2
In plain English
A high-severity code injection in shopware from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Shopware is an open commerce platform. From 6.7.0.0 to before 6.7.6.1, a regression of CVE-2023-2017 leads to an array and array crafted PHP Closure not checked being against allow list for the map(...) override. This vulnerability is fixed in 6.7.6.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | shopware/core | 6.7.6.1 | GHSA-7cw6-7h3h-v8pf |
| Packagist | shopware/shopware | 6.7.6.1 | GHSA-7cw6-7h3h-v8pf |
Affected products (as reported)
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H