Vulnerability · Published Mar 23, 2026 · Assigned by GitHub_M
CVE-2026-23480Blinko: Low Privilege User Privilege Escalation - upsertUser Endpoint
Medium 5.3
In plain English
A medium-severity authentication bypass in blinko from blinkospace. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities).
Official description
Blinko is an AI-powered card note-taking project. Prior to version 1.8.4, there is a privilege escalation vulnerability. The upsertUser endpoint has 3 issues: it is missing superAdminAuthMiddleware, any logged-in user can call it; the originalPassword is an optional parameter and if not provided password verification is skipped; there is no check for input.id === ctx.id (ownership verification). This could result in any authenticated user modifying other users' passwords, direct escalation to superadmin, and complete account takeover. This issue has been patched in version 1.8.4.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| blinkospace | blinko | < 1.8.4 |
Weakness: CWE-288 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N