Vulnerability · Published Jan 12, 2026 · Assigned by GitHub_M

CVE-2026-22813Malicious website can execute commands on the local system through XSS in the OpenCode web UI

Critical 9.4

In plain English

A critical-severity cross-site scripting in opencode from anomalyco. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.4Critical
Exploit odds (30 days)0.9%top 40.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

OpenCode is an open source AI coding agent. The markdown renderer used for LLM responses will insert arbitrary HTML into the DOM. There is no sanitization with DOMPurify or even a CSP on the web interface to prevent JavaScript execution via HTML injection. This means controlling the LLM response for a chat session gets JavaScript execution on the http://localhost:4096 origin. This vulnerability is fixed in 1.1.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmopencode-ai1.1.10GHSA-c83v-7274-4vgp

Affected products (as reported)

VendorProductVersions
anomalyco opencode < 1.1.10

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

References