Vulnerability · Published Jan 12, 2026 · Assigned by GitHub_M
CVE-2026-22812OpenCode's Unauthenticated HTTP Server Allows Arbitrary Command Execution
High 8.8
In plain English
A high-severity missing authentication in opencode from anomalyco. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 16.5% (higher than 97% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
OpenCode is an open source AI coding agent. Prior to 1.0.216, OpenCode automatically starts an unauthenticated HTTP server that allows any local process (or any website via permissive CORS) to execute arbitrary shell commands with the user's privileges. This vulnerability is fixed in 1.0.216.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | opencode-ai | 1.0.216 | GHSA-vxw4-wv6m-9hhh |
Affected products (as reported)
Weakness: CWE-306, CWE-749, CWE-942 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/anomalyco/opencode/security/advisories/GHSA-vxw4-wv6m-9hhh x_refsource_CONFIRM