Vulnerability · Published Jan 14, 2026 · Assigned by GitHub_M

CVE-2026-22787html2pdf.js has a cross-site scripting vulnerability

High 8.7

In plain English

A high-severity cross-site scripting in html2pdf.js from eKoopmans. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.4%top 66.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

html2pdf.js converts any webpage or element into a printable PDF entirely client-side. Prior to 0.14.0, html2pdf.js contains a cross-site scripting (XSS) vulnerability when given a text source rather than an element. This text is not sufficiently sanitized before being attached to the DOM, allowing malicious scripts to be run on the client browser and risking the confidentiality, integrity, and availability of the page's data. This vulnerability has been fixed in html2pdf.js@0.14.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmhtml2pdf.js0.14.0GHSA-w8x4-x68c-m6fc

Affected products (as reported)

VendorProductVersions
eKoopmans html2pdf.js < 0.14.0

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N

References