Vulnerability · Published Jan 12, 2026 · Assigned by GitHub_M
CVE-2026-22785orval MCP client is vulnerable to a code injection attack.
Critical 9.3
In plain English
A critical-severity command injection in orval from orval-labs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
orval generates type-safe JS clients (TypeScript) from any valid OpenAPI v3 or Swagger v2 specification. Prior to 7.18.0, the MCP server generation logic relies on string manipulation that incorporates the summary field from the OpenAPI specification without proper validation or escaping. This allows an attacker to "break out" of the string literal and inject arbitrary code. This vulnerability is fixed in 7.18.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @orval/mcp | 7.18.0 | GHSA-mwr6-3gp8-9jmj |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| orval-labs | orval | < 7.18.0 |
Weakness: CWE-77 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N