Vulnerability · Published Jan 10, 2026 · Assigned by GitHub_M
CVE-2026-22777ComfyUI-Manager is Vulnerable to CRLF Injection in Configuration Handler
High 7.5
In plain English
A high-severity security flaw in ComfyUI-Manager from Comfy-Org. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
ComfyUI-Manager is an extension designed to enhance the usability of ComfyUI. Prior to versions 3.39.2 and 4.0.5, an attacker can inject special characters into HTTP query parameters to add arbitrary configuration values to the config.ini file. This can lead to security setting tampering or modification of application behavior. This issue has been patched in versions 3.39.2 and 4.0.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | comfy-cli | 4.0.5 | GHSA-562r-8445-54r2 |
| PyPI | comfy-cli | 3.39.2 | GHSA-562r-8445-54r2 |
| PyPI | comfy-cli | 3.39.2, 4.0.5 | PYSEC-2026-1260 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Comfy-Org | ComfyUI-Manager | >= 4.0.0, < 4.0.5< 3.39.2 |
Weakness: CWE-93 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N