Vulnerability · Published Jan 15, 2026 · Assigned by GitHub_M

CVE-2026-22775devalue vulnerable to denial of service due to memory/CPU exhaustion in devalue.parse

High 7.5

In plain English

A high-severity security flaw in devalue from sveltejs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 49.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From 5.1.0 to 5.6.1, certain inputs can cause devalue.parse to consume excessive CPU time and/or memory, potentially leading to denial of service in systems that parse input from untrusted sources. This affects applications using devalue.parse on externally-supplied data. The root cause is the ArrayBuffer hydration expecting base64 encoded strings as input, but not checking the assumption before decoding the input. This vulnerability is fixed in 5.6.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmdevalue5.6.2GHSA-g2pg-6438-jwpf

Affected products (as reported)

VendorProductVersions
sveltejs devalue >= 5.1.0, < 5.6.2

Weakness: CWE-405 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References