Vulnerability · Published Jan 10, 2026 · Assigned by GitHub_M
CVE-2026-22610Angular has XSS Vulnerability via Unsanitized SVG Script Attributes
High 8.5
In plain English
A high-severity cross-site scripting in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0, a cross-site scripting (XSS) vulnerability has been identified in the Angular Template Compiler. The vulnerability exists because Angular’s internal sanitization schema fails to recognize the href and xlink:href attributes of SVG <script> elements as a Resource URL context. This issue has been patched in versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | angular.js | no fix listed | DEBIAN-CVE-2026-22610 |
| Debian:13 | angular.js | no fix listed | DEBIAN-CVE-2026-22610 |
| Debian:14 | angular.js | no fix listed | DEBIAN-CVE-2026-22610 |
| Ubuntu:22.04:LTS | angular.js | no fix listed | UBUNTU-CVE-2026-22610 |
| Ubuntu:24.04:LTS | angular.js | no fix listed | UBUNTU-CVE-2026-22610 |
| Ubuntu:25.10 | angular.js | no fix listed | UBUNTU-CVE-2026-22610 |
| Ubuntu:26.04:LTS | angular.js | no fix listed | UBUNTU-CVE-2026-22610 |
| Ubuntu:26.10 | angular.js | no fix listed | UBUNTU-CVE-2026-22610 |
| npm | @angular/compiler | 21.1.0-rc.0 | GHSA-jrmj-c5cx-3cw6 |
| npm | @angular/compiler | 21.0.7 | GHSA-jrmj-c5cx-3cw6 |
| npm | @angular/compiler | 20.3.16 | GHSA-jrmj-c5cx-3cw6 |
| npm | @angular/compiler | 19.2.18 | GHSA-jrmj-c5cx-3cw6 |
| npm | @angular/compiler | no fix listed | GHSA-jrmj-c5cx-3cw6 |
| npm | @angular/core | no fix listed | GHSA-jrmj-c5cx-3cw6 |
| npm | @angular/core | 19.2.18 | GHSA-jrmj-c5cx-3cw6 |
| npm | @angular/core | 20.3.16 | GHSA-jrmj-c5cx-3cw6 |
| npm | @angular/core | 21.0.7 | GHSA-jrmj-c5cx-3cw6 |
| npm | @angular/core | 21.1.0-rc.0 | GHSA-jrmj-c5cx-3cw6 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/angular/angular/security/advisories/GHSA-jrmj-c5cx-3cw6 x_refsource_CONFIRM
- https://github.com/angular/angular/pull/66318 x_refsource_MISC
- https://github.com/angular/angular/commit/91dc91bae4a1bbefc58bef6ef739d0e02ab44d56 x_refsource_MISC
- https://cert-portal.siemens.com/productcert/html/ssa-485750.html
- https://cert-portal.siemens.com/productcert/html/ssa-253495.html