Vulnerability · Published Feb 6, 2026 · Assigned by GitHub_M
CVE-2026-22592Gogs is Vulnerable to Denial of Service
Medium 6.5
In plain English
A medium-severity missing authorization in gogs from gogs. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.4%top 68.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, an authenticated user can cause a DOS attack. If one of the repo files is deleted before synchronization, it will cause the application to crash. This issue has been patched in versions 0.13.4 and 0.14.0+dev.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | gogs.io/gogs | 0.13.4 | GHSA-cr88-6mqm-4g57 |
| Go | gogs.io/gogs | no fix listed | GO-2026-4451 |
Affected products (as reported)
Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/gogs/gogs/security/advisories/GHSA-cr88-6mqm-4g57 x_refsource_CONFIRM