Vulnerability · Published Jan 21, 2026 · Assigned by apache
CVE-2026-22444Apache Solr: Insufficient file-access checking in standalone core-creation requests
High 7.1
In plain English
A high-severity improper input validation in Apache Solr from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
The "create core" API of Apache Solr 8.6 through 9.10.0 lacks sufficient input validation on some API parameters, which can cause Solr to check the existence of and attempt to read file-system paths that should be disallowed by Solr's "allowPaths" security setting https://https://solr.apache.org/guide/solr/latest/configuration-guide/configuring-solr-xml.html#the-solr-element . These read-only accesses can allow users to create cores using unexpected configsets if any are accessible via the filesystem. On Windows systems configured to allow UNC paths this can additionally cause disclosure of NTLM "user" hashes. Solr deployments are subject to this vulnerability if they meet the following criteria: * Solr is running in its "standalone" mode. * Solr's "allowPath" setting is being used to restrict file access to certain directories. * Solr's "create core" API is exposed and accessible to untrusted users. This can happen if Solr's RuleBasedAuthorizationPlugin https://solr.apache.org/guide/solr/latest/deployment-guide/rule-based-authorization-plugin.html is disabled, or if it is enabled but the "core-admin-edit" predefined permission (or an equivalent custom permission) is given to low-trust (i.e. non-admin) user roles. Users can mitigate this by enabling Solr's RuleBasedAuthorizationPlugin (if disabled) and configuring a permission-list that prevents untrusted users from creating new Solr cores. Users should also upgrade to Apache Solr 9.10.1 or greater, which contain fixes for this issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.solr:solr-core | 9.10.1 | GHSA-vc2w-4v3p-2mqw |
| Ubuntu:22.04:LTS | lucene-solr | no fix listed | UBUNTU-CVE-2026-22444 |
| Ubuntu:24.04:LTS | lucene-solr | no fix listed | UBUNTU-CVE-2026-22444 |
| Ubuntu:25.10 | lucene-solr | no fix listed | UBUNTU-CVE-2026-22444 |
| Ubuntu:26.04:LTS | lucene-solr | no fix listed | UBUNTU-CVE-2026-22444 |
| Ubuntu:26.10 | lucene-solr | no fix listed | UBUNTU-CVE-2026-22444 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Solr | 8.6 – through 9.10.0 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N