Vulnerability · Published Jan 12, 2026 · Assigned by GitHub_M
CVE-2026-22250wlc can skip SSL verification
Low 2.5
In plain English
A low-severity improper certificate validation in wlc from WeblateOrg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 5% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)2.5Low
Exploit odds (30 days)0.2%top 95.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, the SSL verification would be skipped for some crafted URLs. This vulnerability is fixed in 1.17.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | wlc | no fix listed | DEBIAN-CVE-2026-22250 |
| Debian:13 | wlc | no fix listed | DEBIAN-CVE-2026-22250 |
| Debian:14 | wlc | 1.17.2-1 | DEBIAN-CVE-2026-22250 |
| PyPI | wlc | 1.17.0 | GHSA-2mmv-7rrp-g8xh |
| PyPI | wlc | 1.17.0 | PYSEC-2026-2051 |
| Ubuntu:25.10 | wlc | 1.15-2ubuntu0.1 | USN-7981-1 |
| Ubuntu:25.10 | wlc | 1.15-2ubuntu0.1 | UBUNTU-CVE-2026-22250 |
| Ubuntu:26.04:LTS | wlc | no fix listed | UBUNTU-CVE-2026-22250 |
| Ubuntu:26.10 | wlc | no fix listed | UBUNTU-CVE-2026-22250 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| WeblateOrg | wlc | < 1.17.0 |
Weakness: CWE-295 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N
References
- https://github.com/WeblateOrg/wlc/security/advisories/GHSA-2mmv-7rrp-g8xh x_refsource_CONFIRM
- https://github.com/WeblateOrg/wlc/pull/1097 x_refsource_MISC
- https://github.com/WeblateOrg/wlc/commit/a513864ec4daad00146e6d6e039559726e256fa3 x_refsource_MISC