Vulnerability · Published Jan 14, 2026 · Assigned by GitHub_M
CVE-2026-22036Undici has an unbounded decompression chain in HTTP responses on Node.js Fetch API via Content-Encoding leads to resource exhaustion
Medium 5.9
In plain English
A medium-severity resource allocation without limits in undici from nodejs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Undici is an HTTP/1.1 client for Node.js. Prior to 7.18.0 and 6.23.0, the number of links in the decompression chain is unbounded and the default maxHeaderSize allows a malicious server to insert thousands compression steps leading to high CPU usage and excessive memory allocation. This vulnerability is fixed in 7.18.0 and 6.23.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-undici | no fix listed | DEBIAN-CVE-2026-22036 |
| Debian:13 | node-undici | no fix listed | DEBIAN-CVE-2026-22036 |
| Debian:14 | node-undici | 7.18.2+dfsg+~cs3.2.0-1 | DEBIAN-CVE-2026-22036 |
| Ubuntu:24.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-22036 |
| Ubuntu:25.10 | node-undici | no fix listed | UBUNTU-CVE-2026-22036 |
| Ubuntu:26.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-22036 |
| Ubuntu:26.10 | node-undici | no fix listed | UBUNTU-CVE-2026-22036 |
| npm | undici | 6.23.0 | GHSA-g9mf-h72j-4rw9 |
| npm | undici | 7.18.2 | GHSA-g9mf-h72j-4rw9 |
Affected products (as reported)
Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H