Vulnerability · Published Jan 8, 2026 · Assigned by GitHub_M

CVE-2026-22034Snuffleupagus vulnerable to RCE on instances with upload validation enabled but without the VLD package

Critical 9.2

In plain English

A critical-severity security flaw in snuffleupagus from jvoisin. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.2Critical
Exploit odds (30 days)0.7%top 46.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Snuffleupagus is a module that raises the cost of attacks against website by killing bug classes and providing a virtual patching system. On deployments of Snuffleupagus prior to version 0.13.0 with the non-default upload validation feature enabled and configured to use one of the upstream validation scripts based on Vulcan Logic Disassembler (VLD) while the VLD extension is not available to the CLI SAPI, all files from multipart POST requests are evaluated as PHP code. The issue was fixed in version 0.13.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14snuffleupagus0.13.0-1DEBIAN-CVE-2026-22034

Affected products (as reported)

VendorProductVersions
jvoisin snuffleupagus < 0.13.0

Weakness: CWE-636 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References