Vulnerability · Published Jan 8, 2026 · Assigned by GitHub_M

CVE-2026-21871NiceGUI is vulnerable to XSS via Unescaped URL in ui.navigate.history.push() / replace()

Medium 6.1

In plain English

A medium-severity cross-site scripting in nicegui from zauberzeug. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.3%top 80.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

NiceGUI is a Python-based UI framework. From versions 2.13.0 to 3.4.1, there is a XSS risk in NiceGUI when developers pass attacker-controlled strings into ui.navigate.history.push() or ui.navigate.history.replace(). These helpers are documented as History API wrappers for updating the browser URL without page reload. However, if the URL argument is embedded into generated JavaScript without proper escaping, a crafted payload can break out of the intended string context and execute arbitrary JavaScript in the victim’s browser. Applications that do not pass untrusted input into ui.navigate.history.push/replace are not affected. This issue has been patched in version 3.5.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPInicegui3.5.0GHSA-7grm-h62g-5m97
PyPInicegui3.5.0PYSEC-2026-1698

Affected products (as reported)

VendorProductVersions
zauberzeug nicegui >= 2.13.0, < 3.5.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References