Vulnerability · Published Aug 4, 2026 · Assigned by VulDB
CVE-2026-18816Baserow 2FA Verify Endpoint views.py verify improper authentication
Medium 5.0
In plain English
A medium-severity improper authentication in Baserow. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities).
Official description
A vulnerability was identified in Baserow up to 2.3.2. Affected by this vulnerability is the function verify of the file backend/src/baserow/api/two_factor_auth/views.py of the component 2FA Verify Endpoint. Such manipulation leads to improper authentication. The attack may be launched remotely. This attack is characterized by high complexity. The exploitation appears to be difficult. Upgrading to version 2.3.3 addresses this issue. You should upgrade the affected component. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Affected products (as reported)
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C
References
- VDB-385815 | Baserow 2FA Verify Endpoint views.py verify improper authentication vdb-entry, technical-description
- VDB-385815 | CTI Indicators (IOB, IOC, IOA) signature, permissions-required
- CVE-2026-18816 | CVE Analysis and Report third-party-advisory
- Submit #857941 | baserow c34eb053be98bc0d04fcbf9b2d6b305cba0d5647 CWE-287 Improper Authentication third-party-advisory
- https://github.com/baserow/baserow/issues/5743 issue-tracking
- https://github.com/baserow/baserow/releases/tag/2.3.3 patch
- https://github.com/baserow/baserow/ product