Vulnerability · Published Aug 3, 2026 · Assigned by AMZN
CVE-2026-18733Prompt injection bypasses shell tool consent gate in Strands Agents Tools
High 8.8
In plain English
A high-severity security flaw in strands-agents-tools from AWS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities).
Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.6%top 52.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
A prompt injection vulnerability in the shell tool in Amazon Strands Agents Tools before 0.8.0 might allow remote actors to execute arbitrary operating system commands on the agent's host via a crafted prompt that sets the non_interactive parameter to true, bypassing the human consent gate. To remediate this issue, users should upgrade to version 0.8.0.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| AWS | strands-agents-tools | 0 – before 0.8.0 |
Weakness: CWE-1427 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://pypi.org/project/strands-agents-tools/0.8.0/ release-notes, patch
- https://aws.amazon.com/security/security-bulletins/2026-072-aws/ vendor-advisory
- https://github.com/strands-agents/tools/security/advisories/GHSA-mqvc-p852-wf8x release-notes