Vulnerability · Published Jul 31, 2026 · Assigned by openjs
CVE-2026-18446fast-uri vulnerable to host confusion via backslash authority introducer
High 7.5
In plain English
A high-severity security flaw in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
fast-uri before 4.1.2, 3.1.5, and 2.4.4 requires a literal double forward slash to recognize a URI authority, so a reference that uses a backslash based introducer in place of it (backslash backslash, forward slash backslash, or backslash forward slash) is parsed with no authority and folds into the path. Node's native WHATWG URL parser instead treats a backslash as interchangeable with a forward slash for special schemes, so the two parsers extract different hosts from the same input. Applications that use fast-uri to enforce host based policy such as allowlists, SSRF filtering, or redirect validation before passing the same URL into Node's URL or fetch consumers can be steered to an unintended host. Upgrade to fast-uri 4.1.2, 3.1.5, or 2.4.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | node-ajv | no fix listed | DEBIAN-CVE-2026-18446 |
| Debian:14 | node-ajv | 8.20.0~ds+~cs7.1.3-1 | DEBIAN-CVE-2026-18446 |
| Ubuntu:22.04:LTS | node-ajv | no fix listed | UBUNTU-CVE-2026-18446 |
| Ubuntu:24.04:LTS | node-ajv | no fix listed | UBUNTU-CVE-2026-18446 |
| Ubuntu:26.04:LTS | node-ajv | no fix listed | UBUNTU-CVE-2026-18446 |
| Ubuntu:26.10 | node-ajv | no fix listed | UBUNTU-CVE-2026-18446 |
| npm | fast-uri | 4.1.2 | GHSA-7p8r-x3mc-p8w7 |
| npm | fast-uri | 3.1.5 | GHSA-7p8r-x3mc-p8w7 |
| npm | fast-uri | 2.4.4 | GHSA-7p8r-x3mc-p8w7 |
Affected products (as reported)
Weakness: CWE-436 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N