Vulnerability · Published Jul 31, 2026 · Assigned by AMZN

CVE-2026-18394Incorrect authorization in Strands Agents Tools http_request proxy credential exfiltration

High 7.4

In plain English

A high-severity incorrect authorization in Strands Agents Tools from AWS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities).

Severity (CVSS 3.1)7.4High
Exploit odds (30 days)0.5%top 55.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Incorrect authorization in the http_request tool in Strands Agents Tools before 0.8.2 might allow remote attackers to obtain credentials configured via HTTP_REQUEST_TOKEN_CONFIG by influencing the LLM to route requests through actor-controlled proxy infrastructure. To remediate this issue, users should upgrade to version 0.8.2.

Affected products (as reported)

VendorProductVersions
AWS Strands Agents Tools 0 – before 0.8.2

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N

References