Vulnerability · Published Jul 29, 2026 · Assigned by openjs

CVE-2026-16728undici vulnerable to downstream response desynchronization via retry interceptor

Medium 4.8

In plain English

A medium-severity security flaw in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.8Medium
Exploit odds (30 days)0.3%top 78.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

undici's retry interceptor can deliver a response whose body length does not match the Content-Length header exposed to the application after a retry or resume of a partial response. In undici before 6.28.0, from 7.0.0 up to before 7.29.0, and from 8.0.0 up to before 8.9.0, a malicious or faulty upstream can return a partial response with a mismatched framing header, close the socket early, and have the retry interceptor assemble a body of a different length while the original Content-Length stays attached. Applications that use the retry interceptor and forward upstream headers and bodies downstream, such as proxies or gateways, may then emit an invalid HTTP response with a stale Content-Length, leading to downstream response desynchronization, connection hangs, or response corruption. Exploitation requires the retry interceptor enabled, an upstream returning a mismatched partial response, and a downstream forwarder that does not remove or recalculate Content-Length. The issue is fixed in undici 6.28.0, 7.29.0, and 8.9.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-undicino fix listedDEBIAN-CVE-2026-16728
Debian:13node-undicino fix listedDEBIAN-CVE-2026-16728
Debian:14node-undici8.9.0+dfsg+~cs3.2.0-1DEBIAN-CVE-2026-16728
Ubuntu:24.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-16728
Ubuntu:26.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-16728
Ubuntu:26.10node-undicino fix listedUBUNTU-CVE-2026-16728
npmundici8.9.0GHSA-8xcm-r25x-g524
npmundici7.29.0GHSA-8xcm-r25x-g524
npmundici6.28.0GHSA-8xcm-r25x-g524

Affected products (as reported)

VendorProductVersions
undici undici 0 – before 6.28.07.0.0 – before 7.29.08.0.0 – before 8.9.0

Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

References