Vulnerability · Published Jul 23, 2026 · Assigned by AMZN
CVE-2026-16584AWS API MCP Server Security Policy Bypass via Startup Failure
High 7.0
In plain English
A high-severity security flaw in aws-api-mcp-server from AWS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper handling of an initialization failure in AWS API MCP Server from 0.2.13 through 1.3.46 might allow an actor to bypass the user-configured security policy and execute AWS API operations that the policy was set to deny or gate. When initialization of the security policy enforcement data fails at server startup, the policy check is skipped for the lifetime of the process. IAM permissions on the configured credentials remain in effect and are unaffected. To remediate this issue, users should upgrade to version 1.3.47.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | awslabs-aws-api-mcp-server | 1.3.47 | GHSA-29w2-fq35-v728 |
| PyPI | awslabs-aws-api-mcp-server | 1.3.47 | PYSEC-2026-3549 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| AWS | aws-api-mcp-server | 0.2.13 – before 1.3.47 |
Weakness: CWE-455 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://pypi.org/project/awslabs.aws-api-mcp-server/1.3.47/ release-notes, patch
- https://aws.amazon.com/security/security-bulletins/2026-063-aws/ vendor-advisory
- https://github.com/awslabs/mcp/security/advisories/GHSA-29w2-fq35-v728 release-notes