Vulnerability · Published Aug 13, 2026 · Assigned by PostgreSQL

CVE-2026-16238PostgreSQL type confusion in pg_restore_attribute_stats() executes arbitrary code

High 8.8

In plain English

A high-severity type confusion in PostgreSQL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.4%top 64.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Type confusion in PostgreSQL pg_restore_attribute_stats() allows an object creator to execute arbitrary code as the operating system user running the database, via conflation of range and multirange values. Within major version 18, minor versions before PostgreSQL 18.6 are affected. Versions before PostgreSQL 18 are unaffected.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:9pg_repack1.5.3-1.module_el9.8.0+234+5456f35dALSA-2026:67848
AlmaLinux:9pgaudit18.0-1.module_el9.8.0+234+5456f35dALSA-2026:67848
AlmaLinux:9pgvector0.8.1-1.module_el9.8.0+234+5456f35dALSA-2026:67848
AlmaLinux:9postgis3.6.1-4.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgis-client3.6.1-4.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgis-docs3.6.1-4.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgis-upgrade3.6.1-4.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgis-utils3.6.1-4.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgres-decoderbufs3.3.1-1.Final.module_el9.8.0+234+5456f35dALSA-2026:67848
AlmaLinux:9postgresql18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-contrib18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-docs18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-plperl18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-plpython318.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-pltcl18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-private-devel18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-private-libs18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-server18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-server-devel18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-static18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-test18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-test-rpm-macros18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-upgrade18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:9postgresql-upgrade-devel18.6-1.module_el9.8.0+310+22372bccALSA-2026:67848
AlmaLinux:10postgresql1818.6-1.el10_2ALSA-2026:67280
AlmaLinux:10postgresql18-contrib18.6-1.el10_2ALSA-2026:67280
AlmaLinux:10postgresql18-docs18.6-1.el10_2ALSA-2026:67280
AlmaLinux:10postgresql18-plperl18.6-1.el10_2ALSA-2026:67280
AlmaLinux:10postgresql18-plpython318.6-1.el10_2ALSA-2026:67280
AlmaLinux:10postgresql18-private-devel18.6-1.el10_2ALSA-2026:67280
AlmaLinux:10postgresql18-private-libs18.6-1.el10_2ALSA-2026:67280
AlmaLinux:10postgresql18-server18.6-1.el10_2ALSA-2026:67280
AlmaLinux:10postgresql18-server-devel18.6-1.el10_2ALSA-2026:67280
AlmaLinux:10postgresql18-static18.6-1.el10_2ALSA-2026:67280
AlmaLinux:10postgresql18-test18.6-1.el10_2ALSA-2026:67280
AlmaLinux:10postgresql18-test-rpm-macros18.6-1.el10_2ALSA-2026:67280
AlmaLinux:10postgresql18-upgrade18.6-1.el10_2ALSA-2026:67280
AlmaLinux:10postgresql18-upgrade-devel18.6-1.el10_2ALSA-2026:67280
Alpine:v3.21postgresql1515.19-r0ALPINE-CVE-2026-16238
Alpine:v3.22postgresql1515.19-r0ALPINE-CVE-2026-16238
Alpine:v3.21postgresql1616.15-r0ALPINE-CVE-2026-16238
Alpine:v3.22postgresql1616.15-r0ALPINE-CVE-2026-16238
Alpine:v3.23postgresql1616.15-r0ALPINE-CVE-2026-16238
Alpine:v3.24postgresql1616.15-r0ALPINE-CVE-2026-16238
Alpine:v3.21postgresql1717.11-r0ALPINE-CVE-2026-16238
Alpine:v3.22postgresql1717.11-r0ALPINE-CVE-2026-16238
Alpine:v3.23postgresql1717.11-r0ALPINE-CVE-2026-16238
Alpine:v3.24postgresql1717.11-r0ALPINE-CVE-2026-16238
Alpine:v3.23postgresql1818.5-r0ALPINE-CVE-2026-16238
Alpine:v3.24postgresql1818.5-r0ALPINE-CVE-2026-16238
Debian:14postgresql-1818.6-1DEBIAN-CVE-2026-16238
Rocky Linux:9pg_repack0:1.5.3-1.module+el9.8.0+40213+f1e225a4RLSA-2026:67848
Rocky Linux:9pg_repack0:1.5.3-1.module+el9.8.0+40158+490b3c67RLSA-2026:67848
Rocky Linux:9pgaudit0:18.0-1.module+el9.8.0+40213+f1e225a4RLSA-2026:67848
Rocky Linux:9pgaudit0:18.0-1.module+el9.8.0+40158+490b3c67RLSA-2026:67848
Rocky Linux:9pgvector0:0.8.1-1.module+el9.8.0+40213+f1e225a4RLSA-2026:67848
Rocky Linux:9pgvector0:0.8.1-1.module+el9.8.0+40158+490b3c67RLSA-2026:67848
Rocky Linux:9postgres-decoderbufs0:3.3.1-1.Final.module+el9.8.0+40158+490b3c67RLSA-2026:67848
Rocky Linux:9postgres-decoderbufs0:3.3.1-1.Final.module+el9.8.0+40213+f1e225a4RLSA-2026:67848
Rocky Linux:10postgresql180:18.6-1.el10_2RLSA-2026:67280
Ubuntu:22.04:LTSpostgresql-1414.24-0ubuntu0.22.04.1USN-8653-1
Ubuntu:24.04:LTSpostgresql-1616.15-0ubuntu0.24.04.1USN-8653-1
Ubuntu:26.04:LTSpostgresql-1818.6-0ubuntu0.26.04.1USN-8653-1
Ubuntu:26.04:LTSpostgresql-1818.6-0ubuntu0.26.04.1UBUNTU-CVE-2026-16238

Affected products (as reported)

VendorProductVersions
n/a PostgreSQL 18 – before 18.6

Weakness: CWE-843 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References