Vulnerability · Published Jul 19, 2026 · Assigned by openjs

CVE-2026-16221fast-uri vulnerable to host confusion via literal backslash authority delimiter

High 7.5

In plain English

A high-severity security flaw in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 62.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Impact: fast-uri versions from 2.3.1 through 4.1.0 (including the 3.x line up to 3.1.3 and the 2.x line up to 2.4.2) do not treat a literal backslash character (U+005C) as an authority delimiter. Node's native WHATWG URL parser, used by fetch, undici, and Node's http and https clients, normalizes the backslash to a forward slash for special schemes such as http, https, ws, wss, ftp, and file. As a result, the two parsers extract different hosts from the same input string. Applications that use fast-uri to enforce host-based policy such as allowlists, denylists, loopback or SSRF filtering, redirect validation, or outbound proxy routing before passing the same URL into Node's URL or fetch consumers can be steered to an unintended destination, including cloud metadata endpoints, loopback, or internal hosts. Patches: upgrade to fast-uri 4.1.1, 3.1.4, or 2.4.3. Workarounds: none.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13node-ajvno fix listedDEBIAN-CVE-2026-16221
Debian:14node-ajv8.20.0~ds+~cs7.1.2-1DEBIAN-CVE-2026-16221
Ubuntu:22.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-16221
Ubuntu:24.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-16221
Ubuntu:26.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-16221
Ubuntu:26.10node-ajvno fix listedUBUNTU-CVE-2026-16221
npmfast-uri4.1.1GHSA-v2hh-gcrm-f6hx
npmfast-uri3.1.4GHSA-v2hh-gcrm-f6hx
npmfast-uri2.4.3GHSA-v2hh-gcrm-f6hx

Affected products (as reported)

VendorProductVersions
fast-uri fast-uri 2.3.1 – before 2.4.33.0.0 – before 3.1.44.0.0 – before 4.1.1

Weakness: CWE-436 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References