Vulnerability · Published Jul 15, 2026 · Assigned by AMZN
CVE-2026-15895OS command injection in jsii-diff in AWS jsii
High 7.8
In plain English
A high-severity OS command injection in jsii from AWS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.1% (higher than 65% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)7.8High
Exploit odds (30 days)1.1%top 34.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
OS command injection in the npm package loading component in AWS jsii-diff before 1.131.0 might allow context-dependent attackers to execute arbitrary commands via crafted package specifiers passed to the npm: source argument. To mitigate this issue, users should upgrade to jsii-diff v1.131.0 or later.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | jsii-diff | 1.131.0 | GHSA-wcx4-wpfv-mc5c |
Affected products (as reported)
Weakness: CWE-78 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/aws/jsii/releases/tag/v1.131.0 release-notes, patch
- https://aws.amazon.com/security/security-bulletins/2026-057-aws/ vendor-advisory