Vulnerability · Published Jul 24, 2026 · Assigned by GoogleCloud
CVE-2026-15810Cross-Site Scripting (XSS) in Looker allows Admin Account Takeover
High 8.7
In plain English
A high-severity cross-site scripting in Looker from Google Cloud. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities).
Official description
A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Google Cloud | Looker | 0 – before 25.6.1030 – before 25.12.650 – before 25.18.680 – before 26.0.660 – before 26.2.470 – before 26.4.360 – before 26.6.280 – before 26.8.7 |
| Google Cloud | Looker | 0 – before 25.6.1030 – before 25.12.650 – before 25.18.680 – before 26.0.660 – before 26.2.470 – before 26.4.360 – before 26.6.280 – before 26.8.7 |
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/U:Amber