Vulnerability · Published Jul 10, 2026 · Assigned by VulDB
CVE-2026-15321MyEMS Admin Backend svg.py on_post cross site scripting
Low 2.4
In plain English
A low-severity cross-site scripting in MyEMS. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities).
Official description
A vulnerability was found in MyEMS up to 6.4.0. The affected element is the function on_post of the file myems-api/core/svg.py of the component Admin Backend. The manipulation of the argument new_values['data'] results in cross site scripting. The attack can be launched remotely. The exploit has been made public and could be used. Upgrading to version 6.5.0 is sufficient to fix this issue. The patch is identified as 4a97edfbd786c779d0322054833b21ddf54d5b06. It is suggested to upgrade the affected component. The issue report remains open even though there is an official fix for it.
Affected products (as reported)
Weakness: CWE-79, CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N/E:P/RL:O/RC:C
References
- VDB-377263 | MyEMS Admin Backend svg.py on_post cross site scripting vdb-entry, technical-description
- VDB-377263 | CTI Indicators (IOB, IOC, TTP, IOA) signature, permissions-required
- CVE-2026-15321 | CVE Analysis and Report third-party-advisory
- Submit #853060 | MyEMS <=6.4.0 Cross Site Scripting third-party-advisory
- https://github.com/MyEMS/myems/issues/412 exploit, issue-tracking
- https://github.com/MyEMS/myems/commit/4a97edfbd786c779d0322054833b21ddf54d5b06 patch
- https://github.com/MyEMS/myems/releases/tag/v6.5.0 patch
- https://github.com/MyEMS/myems/ product